Facebook Business Pages Missing From Page List
Incident Report for Ecamm Live
Resolved
This incident has been resolved.
Posted Sep 26, 2023 - 11:26 EDT
Monitoring
Facebook has implemented a fix for this issue. We are monitoring today to ensure that it has been resolved.
Posted Sep 16, 2023 - 12:27 EDT
Identified
Meta is working to fix an issue that is causing Facebook Business Pages to be missing from Ecamm Live’s Page list.
Posted Sep 13, 2023 - 07:37 EDT
This incident affected: Streaming Platforms (Facebook Live).