Error Messages in Ecamm App

Incident Report for Ecamm

Resolved

This incident has been resolved. If you are still seeing error message connecting to Ecamm servers, try changing your Mac's DNS server, or contact our support team for additional troubleshooting.
Posted Jun 27, 2026 - 09:24 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 26, 2026 - 11:13 EDT

Monitoring

A DNS issue prevented many Ecamm services from functioning on Friday morning.

The issue has been corrected, but users may see connection issues until DNS changes propagate throughout the afternoon.
Posted Jun 26, 2026 - 11:13 EDT
This incident affected: Ecamm App, Ecamm For Zoom, Ecamm Interview, and Website.