Ecamm Live Login Is Unavailable
Incident Report for Ecamm Live
Postmortem

A widespread Amazon Web Services outage caused service interruptions with our login service provider. Amazon resolved the issue within about an hour. We apologize for the interruption this may have caused.

Posted Dec 16, 2021 - 19:59 EST

Resolved
Ecamm Live login is unavailable at this time due an an outage with our login service provider. We are working with our provider for a resolution.
Posted Dec 15, 2021 - 09:30 EST